What Open Source is Used by CTERA Edge Filer
  • 8 Minutes to read
  • Dark
    Light
  • PDF

What Open Source is Used by CTERA Edge Filer

  • Dark
    Light
  • PDF

Article Summary

Apache v1.0, BSD 3-Clause "New" or "Revised", MIT, NCSA, PHP, Zend

php-fpm 7.4.5

Apache v1.0, BSD 3-Clause "New" or "Revised", MIT, NCSA, PHP, PostgreSQL, Zend

php-cli 7.4.5

Apache v2.0

bcc 0.10.0, bcc-tools 0.10.0, ctera-bcc-tools v0.9.0_30_g8e6bd530, python-bcc 0.10.0, python-configshell 1.1.fb25, python-rtslib 2.1.fb69, targetcli 2.1.fb49, filebeat 7.6.2, metricbeat 7.6.2

jingo.js, http://dev.abiss.gr/sarissa, https://github.com/GoogleChrome/web-vitals

Apache v2.0, BSD 3-Clause "New" or "Revised", ISC, LGPL v2+, MIT, Python

python2-pip 8.1.2

Apache v2.0, BSD 3-Clause "New" or "Revised", LGPL v2, MIT, MPL v2.0, Python

python3-pip 9.0.3

Apache v2.0, BSD 3-Clause "New" or "Revised", MIT

python3-setuptools 39.2.0

Apache v2.0, GPL v3+

rsyslog 8.24.0

Artistic 2.0

pv 1.4.6

Boost Software, MIT, Python

boost-chrono 1.53.0, boost-date-time 1.53.0, boost-filesystem 1.53.0, boost-iostreams 1.53.0, boost-program-options 1.53.0’ boost-random 1.53.0, boost-regex 1.53.0, boost-system 1.53.0, boost-thread 1.53.0

Boost Software, Zlib

zlib 1.2.7

BSD 2-Clause "Simplified"

nginx 1.18.0

BSD 3-Clause "New" or "Revised"

bzip2 1.0.6, bzip2-libs 1.0.6, file 5.11, file-libs 5.11, fipscheck 1.4.1, fipscheck-lib 1.4.1, fpart 1.2.0, hdparm 9.43, iperf3 3.1.7, jemalloc 3.6.0, libarchive 3.1.2, libdnet 1.12, libedit 3, libevent 2.0.21, libnfsidmap 0.25, libpmem 1.5.1, libpmemblk 1.5.1, libssh2 1.8.0, libuuid 2.23.2, lighttpd 1.4.20, net-snmp 5.7.2, net-snmp-agent-libs 5.7.2, net-snmp-libs 5.7.2, openssh 7.4p1, openssh-clients 7.4p1, openssh-server 7.4p1, p11-kit 0.23.5, p11-kit-trust 0.23.5, pcre 8.32, python-lxml 3.2.1, python-netaddr 0.7.5, redis 3.2.12, rpcbind 0.2.0, snappy 1.1.0, tcp_wrappers 7.6, tcp_wrappers-libs 7.6, telnet 0.17, trousers 0.3.14, unzip 6, wpa_supplicant 2.6, zip 3, leveldb

fieldpanel.js, Timefield.js, Hourfield.js, Ipfield.js, querystring.js

BSD 3-Clause "New" or "Revised", GPL v1, GPL v3+, LGPL v3, LGPL v3+

gawk 4.0.2

BSD 3-Clause "New" or "Revised", GPL v1+

passwd 0.79

BSD 3-Clause "New" or "Revised", GPL v2

libibverbs 22.4, librdmacm 22.4, rdma-core 22.4

BSD 3-Clause "New" or "Revised", GPL v2, GPL v2+, ISC, MIT

nfs-utils 1.3.0

BSD 3-Clause "New" or "Revised", GPL v2+

iputils 20160308, pam 1.1.8, shadow-utils 4.6, libpwquality 1.2.3, lz4 1.7.5

BSD 3-Clause "New" or "Revised", GPL v2+, ISC, MIT

cronie 1.4.11, cronie-anacron 1.4.11

BSD 3-Clause "New" or "Revised", MIT

figlet 2.2.5

BSD 3-Clause "New" or "Revised", FTL, GPL v2+, MIT, Zlib with acknowledgment, Public Domain

freetype 2.8

BSD 3-Clause "New" or "Revised", GFDL, GPL v3+, MIT

groff-base 1.22.2

BSD 3-Clause "New" or "Revised", GPL v1+, Perl Artistic

perl-PathTools 3.4

BSD 3-Clause "New" or "Revised", GPL v1+, GPL v2+, GPL v2+ with exceptions, GPL v3+, GPL v3+with exceptions, LGPL v2+, Public Domain

gdb 9.1, gdb-gdbserver 9.1

BSD 3-Clause "New" or "Revised", GPL v1+, MIT, Public Domain

xmlrpc-c 1.32.5, xmlrpc-c-client 1.32.5

BSD 3-Clause "New" or "Revised", GPL v2

ustr 1.0.4

BSD 3-Clause "New" or "Revised", GPL v2, GPL v2+, LGPL v2

quota 4.01, quota-nls 4.01

BSD 3-Clause "New" or "Revised", GPL v2 with exceptions, LGPL v2

mariadb-libs 5.5.65

BSD 3-Clause "New" or "Revised", GPL v2, GPL v2+ with exceptions, GPL v3+, GPL v3+with exceptions, LGPL v2+

libgcc 4.8.5, libgomp 4.8.5, libstdc++ 4.8.5

BSD 3-Clause "New" or "Revised", ISC

tmux 1.8

BSD 3-Clause "New" or "Revised", LGPL v2, Sleepycat

libdb 5.3.21, libdb-utils 5.3.21

BSD 3-Clause "New" or "Revised", LGPL v2+, MIT

BSD 3-Clause "New" or "Revised", Sun Industry Standards Source License v1.1

libtirpc 0.2.4

BSD 3-Clause "New" or "Revised", PHP

php-common 7.4.5

BSD with advertising

arpwatch 2.1a15, cyrus-sasl-lib 2.1.26, libpcap 1.5.3, tcpdump 4.9.2

BSD with advertising, GPL v2, GPL v2+, LGPL v2+

util-linux 2.23.2

BSD with advertising, MPL v1.1

mailx 12.5

CDDL-1.0, CDDL-1.1

spax 1.5.2

Creative Commons Attribution Share Alike 2.5 Generic with attribution by Claude Ostyn

Date.js

GPL v1

sysstat 12.3.2

GPL v1+

fuse 2.9.2, fuse3 3.6.1, hardlink 1, kpartx 0.4.9, logrotate 3.16.0, nethogs 0.8.5, smbftpd 2.2

GPL v1+, GPL v2, GPL v2+, GPL v3+, LGPL v2+

procps-ng 3.3.10

GPL v1+, GPL v2+

os-prober 1.58

GPL v1+, LGPL v2+

xfsprogs 4.19.0

GPL v1+, LGPL v2+, MIT, Redistributable, No modifications permitted

linux-firmware 20191203

GPL v1+, Perl Artistic

perl-Carp 1.26, perl-constant 1.27, perl-Data-Dumper 2.145, perl-Encode 2.51, perl-Exporter 5.68, perl-File-Path 2.09, perl-File-Temp 0.23.01, perl-Filter 1.49, perl-HTTP-Tiny 0.033, perl-libs 5.16.3, perl-macros 5.16.3, perl-parent 0.225, perl-Pod-Escapes 1.04, perl-podlators 2.5.1, perl-Pod-Perldoc 3.2, perl-Pod-Simple 3.28, perl-Pod-Usage 1.63, perl-Scalar-List-Utils 1.27, perl-Socket 2.01, perl-Storable 2.45, perl-Text-ParseWords 3.29, perl-threads 1.87, perl-threads-shared 1.43, perl-Time-HiRes 1.9725, perl-Time-Local 1.23

GPL v1+, Perl Artistic, GPL v2+, MIT, UCD, Public Domain, Copyright only

perl 5.16.3

GPL v2

apcupsd 3.14.14, busybox 1.29.3, centos-release 7, chkconfig 1.7.4, chrony 3.4, cups-client 1.6.3, device-mapper 1.02.164, device-mapper-event 1.02.164, dstat 0.7.2, ethtool 4.8, fio 3.7, geoipupdate 2.5.0, inotify-tools 3.14, iptables 1.4.21, kernel 4.19.99, kernel-devel 4.19.99, kernel-headers 4.19.99, kernel-tools 4.19.99, kernel-tools-libs 4.19.99, kernel-tools-libs-devel 4.19.99, kexec-tools 2.0.15, lshw B.02.18, lvm2 2.02.186, mlocate 0.26, open-vm-tools 10.3.10, perf 4.19.99, python-ethtool 0.8, redhat-lsb-core 4.1, redhat-lsb-submod-security 4.1, yum-metadata-parser 1.1.4

GPL v2, LGPL v2

e2fsprogs-libs 1.42.9, numactl-libs 2.0.12

GPL v2, GPL v2+with exceptions , GPL v3+, Verbatim, Copyright only

gpm-libs 1.20.7

GPL v2+

abrt 2.1.11, abrt-addon-ccpp 2.1.11, abrt-addon-kerneloops 2.1.11, abrt-addon-pstoreoops 2.1.11, abrt-addon-python 2.1.11, abrt-addon-vmcore 2.1.11, abrt-addon-xorg 2.1.11, abrt-cli 2.1.11, abrt-dbus 2.1.11, abrt-libs 2.1.11, abrt-python 2.1.11, abrt-retrace-client 2.1.11, abrt-tui 2.1.11m acl 2.2.51, atop 2.4.0, attr 2.4.46, bc 1.06.95, ccze 0.2.1, dmidecode 3.2, grubby 8.28, hostname 3.13, htop 2.2.0, hwdata 0.252, iftop 1, iotop 0.6, kmod 20, libnetfilter_conntrack 1.0.6, libnfnetlink 1.0.1, libreport 2.1.11, libreport-centos 2.1.11, libreport-cli 2.1.11, libreport-filesystem 2.1.11, libreport-plugin-mantisbt 2.1.11, libreport-plugin-rhtsupport 2.1.11, libreport-plugin-ureport 2.1.11, libreport-python 2.1.11, libreport-web 2.1.11, ltrace 0.7.91, lzo 2.06, make 3.82, mdadm 4.1, mtr 0.85, net-tools 2, NetworkManager 1.18.4, NetworkManager-libnm 1.18.4, ntfs-3g 2017.3.23, ntfsprogs 2017.3.23, nvme-cli 1.8.1, pciutils 3.5.1, pciutils-libs 3.5.1, pinentry 0.8.1, pkgconfig 0.27.1, psmisc 22.2, rpm 4.11.3, rpm-python 4.11.3, satyr 0.13, screen 4.1.0, shared-mime-info 1.8, slang 2.2.4, smartmontools 7, sos 3.8, ssmtp 2.64, sysvinit-tools 2.88, time 1.7, traceroute 2.0.22, tree 1.6.0, usbutils 7, virt-what 1.18, yum 3.4.3, yum-plugin-fastestmirror 1.1.31, yum-utils 1.1.31, initscripts 9.49.49
https://github.com/risacher/davclient.js

GPL v2+AFL

dbus-glib 0.1, dbus 1.10.24, dbus-libs 1.10.24

GPL v2+, GPL v3+

man-db 2.6.3, nut 2.7.2, nut-client 2.7.2

GPL v2+, GPL v3+, ISC, MIT, Public Domain

at 3.1.13

GPL v2+, GPL v3+, LGPL v3+

elfutils 0.176

GPL v2+, GPL v3+, LGPL v2+, Public Domain

lm_sensors 3.4.0, lm_sensors-libs 3.4.0

GPL v2+, LGPL v2+

cryptsetup 2.0.3, cryptsetup-libs 2.0.3, dracut 33, dracut-network 33, keyutils 1.5.8, keyutils-libs 1.5.8

GPL v2+, LGPL v2+, Creative Commons Attribution Share Alike

GeoIP 1.5.0

GPL v2+, LGPL v2+, MIT

systemd 219

GPL v2+, LGPL v2+, MPL v1.1

mozjs17 17.0.0

GPL v2+, LGPL v2+, LGPL v2+ with exceptions

glibc 2.17, glibc-common 2.17

GPL v2+, LGPL v2+ with exceptions

rpm-build-libs 4.11.3, rpm-libs 4.11.3

GPL v2+, LGPL v2.1+

strace 4.24

GPL v2+, LGPL v2.1+, LGPL v3+

gmp 6.0.0, elfutils-default-yama-scope 0.176, elfutils-libelf 0.176, elfutils-libs 0.176

GPL v2+, Perl Artistic

perl-Getopt-Long 2.4

GPL v3

cifs-utils 6.2, which 2.2

GPL v3+

bash 4.2.46, binutils 2.27, coreutils 8.22, cpio 2.11, device-mapper-persistent-data 0.8.5, diffutils 3.3, ed 1.9, findutils 4.5.11, freeipmi 1.5.7, gdbm 1.1, gnupg2 2.0.22, grep 2.2, grub2 2.02, grub2-common 2.02, grub2-pc 2.02, grub2-pc-modules 2.02, grub2-tools 2.02, grub2-tools-extra 2.02, grub2-tools-minimal 2.02, haveged 1.9.1, info 5.1, less 458, libbasicobjects 0.1.1, libpipeline 1.2.3, m4 1.4.16, nano 2.3.1, parted 3.1, patch 2.7.1, readline 6.2, rsync 3.1.2, sed 4.2.2, tar 1.26, wget 1.14

GPL v3+, GFDL

gzip 1.5

GPL v3+, LGPL v2+

gettext 0.19.8.1, gnutls 3.3.29, libtasn1 4.1, gettext-libs 0.19.8.1, libassuan 2.1.0

GPL v3+, GFDL, LGPL v2+

libidn 1.28

GPL v3+, LGPL v3+

ctdb 4.6.16, libsmbclient 4.6.16, libwbclient 4.6.16, samba 4.6.16, samba-client 4.6.16, samba-client-libs 4.6.16, samba-common 4.6.16, samba-common-libs 4.6.16, samba-common-tools 4.6.16, samba-dc 4.6.16, samba-dc-libs 4.6.16, samba-libs 4.6.16, samba-python 4.6.16, samba-test 4.6.16, samba-test-libs 4.6.16, samba-winbind 4.6.16, samba-winbind-clients 4.6.16, samba-winbind-modules 4.6.16

ISC

dhclient 4.2.5, dhcp-common 4.2.5, dhcp-libs 4.2.5, sudo 1.8.23

[LGPL v2] https://spdx.org/licenses/LGPL-2.0-only.html){target=_blank}

daxctl-libs 65, device-mapper-event-libs 1.02.164, device-mapper-libs 1.02.164, dialog 1.2, libcroco 0.6.12, libmspack 0.5, libnl 1.1.4, libnl3 3.2.28, libseccomp 2.3.1, lvm2-libs 2.02.186, ndctl-libs 65, python-chardet 2.2.1, librados2 10.2.5, librbd1 10.2.5

[LGPL v2] https://spdx.org/licenses/LGPL-2.0-only.html){target=_blank}, Zlib

cups-libs 1.6.3

LGPL v2+

audit-libs 2.8.5, augeas-libs 1.4.0, avahi 0.6.31, avahi-libs 0.6.31, cracklib 2.9.0, cracklib-dicts 2.9.0, fuse-libs 2.9.2, glib2 2.56.1, gpgme 1.3.2, kmod-libs 20, libacl 2.2.51, libaio 0.3.109, libattr 2.4.46, libblkid 2.23.2, libcap 2.22, libcap-ng 0.7.5, libdaemon 0.14, libesmtp 1.0.6, libestr 0.1.9, libgcrypt 1.5.3, libgpg-error 1.12, libmnl 1.0.3, libmodman 2.0.1, libmount 2.23.2, libndp 1.2, libproxy 0.4.11, libsemanage 2.5, libsepol 2.5, libsmartcols 2.23.2, libtool-ltdl 2.4.2, libusb 0.1.4, libusbx 1.0.21, libuser 0.6, libutempter 1.1.6, nettle 2.7.1, polkit 0.112, polkit-pkla-compat 0.1, pth 2.0.7, pygobject2 2.28.6, pygpgme 0.3, python-augeas 0.5.0, python-kitchen 1.1.1, python-kmod 0.9, python-pyudev 0.15, python-urlgrabber 3.1, python-urwid 1.1.1, pyxattr 0.5.1, qrencode-libs 3.4.1, systemd-python 219, systemd-sysv 219, xz 5.2.2, xz-libs 5.2.2

LGPL v2+, MIT

systemd-libs 219, python-pycurl 7.19.0

LGPL v2+, Sendmail, Zlib

lsof 4.87

LGPL v3+

libcollection 0.7.0, libini_config 1.3.1, libpath_utils 0.2.1, libref_array 0.1.5, libunistring 0.9.3, pyliblzma 0.5.3

MIT

JSON

MIT

cpp_redis 4.3.1, curl 7.29.0, dbus-python 1.1.1, expat 2.1.0, gssproxy 0.7.0, json-c 0.11, krb5-libs 1.15.1, libcom_err 1.42.9, libcurl 7.29.0, libdrm 2.4.97, libfastjson 0.99.4, libpciaccess 0.14, libtar 1.2.11, libverto 0.2.5, libverto-tevent 0.2.5, libxml2 2.9.1, libxml2-python 2.9.1, libxslt 1.1.28, lua 5.1.4, ncurses 5.9, ncurses-base 5.9, ncurses-libs 5.9, popt 1.13, pyparsing 1.5.6, python2-redis 2.10.6, python36-six 1.12.0, python-iniparse 0.4, python-six 1.9.0, xmlsec1 1.2.20, xmlsec1-openssl 1.2.20, xmlstarlet 1.6.1
https://github.com/pipwerks/PDFObject, https://zenorocha.github.io/clipboard.js, https://momentjs.com/, https://jquery.org/, https://github.com/walling/unorm, https://reactjs.org/, https://mui.com/, https://emotion.sh/, https://github.com/JedWatson/classnames, https://github.com/Qix-/color,https://github.com/remix-run/history,
https://www.i18next.com/, https://github.com/i18next/i18next-chained-backend, https://github.com/i18next/i18next-http-backend, https://github.com/i18next/i18next-http-middleware, https://github.com/i18next/i18next-resources-to-backend, https://react.i18next.com/, https://github.com/lodash/lodash, https://github.com/jcoreio/material-ui-popup-state,
https://github.com/remix-run/react-router, https://www.npmjs.com/package/react-router-dom, https://github.com/styled-components/styled-components, https://www.npmjs.com/package/use-http

MPL v1.1

nss-pem 1.0.3

MPL v2.0

bind-export-libs 9.11.4, bind-libs 9.11.4, bind-libs-lite 9.11.4, bind-license 9.11.4, bind-utils 9.11.4, nspr 4.21.0, nss 3.44.0, nss-softokn 3.44.0, nss-softokn-freebl 3.44.0, nss-sysinit 3.44.0, nss-tools 3.44.0, nss-util 3.44.0

NCSA

llvm-private 7.0.1

Open Market License

fcgi 2.4.0

OpenLDAP

openldap 2.4.44

OpenSSL

openssl 1.0.2zd, openssl-libs 1.0.2u

[PHP https://spdx.org/licenses/PHP-3.01.html){target=_blank}

php-json 7.4.5, php-pdo 7.4.5, php-process 7.4.5, php-xml 7.4.5

pubkey

gpg-pubkey 00f97f56, gpg-pubkey 352c64e5, gpg-pubkey 7bd9bf62, gpg-pubkey d88e42b4, gpg-pubkey f4a80eb5

Public Domain

basesystem 10, ca-certificates 2019.2.32, filesystem 3.2, libselinux 2.5, libtomcrypt 1.17, libtommath 0.42.0, python-backports 1, setup 2.8.71, sqlite 3.30.1, tzdata 2019c

Public Domain, GPL v2

crontabs 1.11

Public Domain, GPL v2+

iproute 4.11.0

Public Domain, MIT

libffi 3.0.13

Public Domain, MIT, UCD

libicu 50.2

Public Domain, Python

python2-crypto 2.6.

Python

python 2.7.5, python2-futures 3.1.1, python3 3.6.8, python36-dateutil 2.4.2, python3-libs 3.6.8, python-backports-ssl_match_hostname 3.5.0.1, python-ipaddress 1.0.16, python-libs 2.7.5

Python, ZPL v2

python-setuptools 0.9.8

Vim

vim-common 7.4.629, vim-enhanced 7.4.629, vim-filesystem 7.4.629, vim-minimal 7.4.629

Zlib

libpng 1.5.13

Non-open Source 3rd-party

Packages

  • Commercial. See the COPYRIGHT file for details: MFEcma 5.6.3, MFErt 2
  • Proprietary: McAfeeESP 10.6.9, McAfeeESPAac 10.6.9, McAfeeESPFileAccess 10.6.9, McAfeeRt 10.6.9, McAfeeTP 10.6.9

Commercial Licenses

  • Commercial OEM License: https://github.com/moxiecode/plupload
  • MIT, Commercial: https://github.com/Accusoft/prizmdoc-viewer
  • Commercial License: Extjs 3.4
  • Roundicons: https://roundicons.com/native-line-solid-icons-pack/

Cache Assist Edge Filer Add-on for macOS

Cocos Pod: Sparkle


Was this article helpful?